Kbase P12614: Appserver becomes unstable after receiving lock table overflow error 915
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/09/2008 |
|
Status: Verified
SYMPTOM(s):
Appserver becomes unstable after receiving lock table overflow error 915
Lock table overflow, increase -L on server (915)
SYSTEM ERROR: ixfil called during resyncing (1062)
SYSTEM ERROR: rmmak called during resyncing (1068)
Begin transaction backout. (2252)
Transaction backout completed. (2253)
AppServer process dies with error 1062 reported in the server log file
AppServer process crashes
Stack trace reads:
RaiseException
utcore
drexit
msgout
msgnCB
msgCB
dsmFatalMsgnCallBack
cxCreateIndex
dsmObjectCreate
proixfc
fdixfilc
scget_ttblfild
rnreloc
rnproc_entry
rninterpret
FACT(s) (Environment):
Progress 9.1D
Progress 9.1B
Progress 9.1C
OpenEdge 10.0x
All Supported Operating Systems
CAUSE:
Bug# OE00095300
CAUSE:
When an application causes a lock table overflow, the AppServer improperly handled the condition and became unstable as a result.
FIX:
Upgrade to Porgress 9.1E or later or OpenEdge 10.1A or later. The AppServer will return to being useful again for the next call, once the client in question is forcibly disconnected from the AppServer session. This is because locktable overflow is considered a serious application error.
A temporary workaround is to correct the coding errors reported prior to the error 1062 and in case error 915 is reported as well, to increase the -L database startup parameter.