Consultor Eletrônico



Kbase P11984: Users hang when trying to connect or disconnect the database on Progress 8.3A or 8.3B
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   26/09/2008
Status: Verified

SYMPTOM(s):

Users hang when trying to connect to the database.

Users hang when trying to disconnect from the database.

Users hang when running promon or proshut against the database.

All users currently in the database continue to work fine.

Lots of error 562 and/or error 298 in the database log file.

HANGUP signal received. (562)

KILL signal received. (298)

FACT(s) (Environment):

All Supported Operating Systems
Progress 8.3A
Progress 8.3B

CAUSE:

Bug# 19991007-002

CAUSE:

Bug# 19990621-030

CAUSE:

Bug# 19991109-025

CAUSE:

The code for logging users into the database was changed slightly for 8.3A, with the intention of optimizing it. However, this unfortunately introduced some bugs. Under certain circumstances, the changes meant that the login semaphore was locked, and if a subsequent error occurred, it was not unlocked.

FIX:

Upgrade to Progress 8.3C or 9.0C or 9.1A or later.
Shutting down the database and restarting it will resolve this problem only temporarily (the shared memory and semaphores are removed on shutdown).
A workaround is to increase the -semset startup parameter.
If this keeps happening, then you have a potential bug.
In all circumstances, an upgrade to the latest Progress version is advised.