Consultor Eletrônico



Kbase P11797: Applying Service Pack errors with invalid configuration
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   31/12/2008
Status: Verified

SYMPTOM(s):

Installed Progress FCS version sucessfully

Installed OpenEdge FCS version sucessfully

When applying Service Pack, getting installation error 139

The entered configuration information is incorrect. Re-enter the configuration
data.

INSTALLATION ERROR (139): The entered configuration information is incorrect. Re-enter the configuration data.

An application error has occurred and an application error log is being generated.

_INS5576._MP.exe Exception: access violation (0xc0000005), Address: 0x77f6ce4c

Installing Service Pack from setup.exe icon errors with "invalid configuration entered please re-enter"

showcfg lists default progress.cfg instead of the Progress "green paper" serial numbers.

FACT(s) (Environment):

Progress 9.1D
All Supported Operating Systems
Progress 9.1E
OpenEdge 10.x

CAUSE:

Default Progress cfg (SN 000015001) overwrites the installed progress.cfg when installing directly over the Progress 9.1D installation or "copying" the unzipped files accross to the Progress directory instead of running setup.exe

Essentially, the progress.cfg file has been overwritten by applying Service Pack 9.1D01 incorrectly.

FIX:

Service Packs are different to Patches in that they are wrapped with their own "install" routine.

1.) Unzip the Service Pack to its own TEMPORARY folder
2.) Install the Service Pack (run setup.exe) and follow instructions