Consultor Eletrônico



Kbase P11680: Dynamart user authentication filters not working when dynama
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   18/03/2003
Status: Unverified

FACT(s) (Environment):

Windows

FACT(s) (Environment):

CorVu 4.1.05

SYMPTOM(s):

Dynamart user authentication filters not working when dynamart is viewed using an ocx over an intranet.

Using OCX to view dynamart on intranet.

Dynamart has authentication filters applied.

Filters work when the dynamart is used in a local CorVu installation.

CAUSE:

In order for the filters defined on a dynamart to work over an intranet, authentication also has to be set at the intranet authentication level.

For example:

1. create a DYNAMART in which some users are defined with the respective groups. 2. create a report using this DYNAMART, setting up some filters which prompt for authentication from the user.

If you use such a report with a local installation of Corvu, it prompts for authentication, applying the defined filter.

If the same report is published on the intranet and displayed in IE, it does not prompt for authentication, but shows all the data.

FIX:

Ensure that authentication is also set at the intranet authentication level.

If you are unsure how to do this, contact your system
etwork administrator.