Kbase P11534: Error 142 when trying to update a record
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  09/06/2009 |
|
Status: Verified
SYMPTOM(s):
Error 142 trying to update a record
** Unable to update <filename> Field. (142)
FACT(s) (Environment):
All Supported Operating Systems
Progress 8.x
Progress 9.x
OpenEdge 10.x
CAUSE:
Record is out of scope
FIX:
Make sure that the record is still available when you are trying to update it.
Sample code:
FOR EACH customer:
END.
ASSIGN customer.name = "xxxx".
The above example, the customer record is no longer available after the END command.
A possible solution is to the above sample is to move the ASSIGN before the END statement.
FOR EACH customer:
ASSIGN customer.name = "xxxx".
END.
END.