Consultor Eletrônico



Kbase P11518: Extent exceeds 2 GB file size limit - Enable large file support
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   02/11/2004
Status: Verified

FACT(s) (Environment):

Progress 9.1C
Progress 9.1D
OpenEdge 10.x

SYMPTOM(s):

Extent exceeds 2 GB limit

<function>:Insufficient disk space during <system call>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (6091)

<function>:Insufficient disk space during <system call>, fd <file descriptor>, len <bytes>, offset 2147467264, file <file-name>. (6091)

bkxtn: write error, file <file-name> errno: <number>. (3646)

SYSTEM ERROR: File <file-name> too small <length>, blocksize <blocksize> extend failed." (4524)

Unable to extend data files enough to proceed. (6743)

SYSTEM ERROR: Attempted to exceed maximum size on file <pname>. (9452)

File system configured for Large File Support

CAUSE:

File size is near the 2 GB limit and could not be extended in order to be written to.

FIX:

The error messages indicate the file size is near the 2 GB limit and could not be extended in order written to.

In the case of Progress 9.1C or later, this could mean:

1) The file system was not created with large file support.

For an operating system to support large files, the file system must be created with large file support. This is done via an operating system administration utility or an option supplied to mkfs or crfs to include large file support. It generally can not be "turned on' after the file system has been created.

2) Operating System ulimit issue.

Users ulimit -f is not set large enough for them to create a file greater than 2 gig.

3) Large file support was not enabled on the Progress database.

If your file system accommodates large files, and ulimit is set appropriately, then all you need to do is to enable large file support in Progress.

$ proutil dbname -C EnableLargeFiles
Once Large File Support is enabled, restart the database and it should proceed through crash recovery.