Consultor Eletrônico



Kbase P11492: Load of the Table Contents (.d) files fails with (132)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/31/2008
Status: Verified

SYMPTOM(s):

Load of the Table Contents (.d) files fails with (132)

** <file-name> already exists with <field/value...>. (132)

.d files fail to load into a Progress database

FACT(s) (Environment):

All Supported Operating Systems
Progress/OpenEdge Product Family
OpenEdge Category: Database

CAUSE:

During the load of data files (.d) using the Data Administration tool, the load might terminate with error (132). The error appears in the Progress generated error file (table_name.e) in the working directory, if the appropriate option was checked at load time.

If a previous load had failed and (for example) revealed that only 10 out of 83 records were loaded into the database, the first 10 records ARE already in the database.

Therefore, next time that data are loaded into the database, for example into the same table, the existing records in the database either need to be deleted, or delete the rows of data that were loaded from the .d file already. By not deleteing the partially loaded data from the table or from the .d file, the data load will terminate with similar messages in the corresponding .e file:

With the Progress database:

>> ERROR READING LINE #1 (Offset=0): ** Customer already exists with Cust Num 1. (132)
** Tolerable load error rate is: 0%.
** Loading table Customer is stopped after 1 error(s).
>> ERROR! Trailer indicated 83 records, but 0 records were loaded.

FIX:

Depending on how many .d's are involved and the size of each:

1) Delete the rows of the partially loaded data in the corresponding .d file.
2) Load the rest of the data.


alternatively:

1) Delete the existing data in the database.
2) Re-dump the data, and load the data again..