Kbase P11269: Unable to stop the adminserver that is running
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/03/2003 |
|
Status: Unverified
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
FACT(s) (Environment):
Progress 9.1C
FACT(s) (Environment):
Progress 9.1D
SYMPTOM(s):
Unable to stop the AdminServer which is running
proadsv -query returns "AdminServer not alive" even though java process is listening on the AdminServer port (20931 by default)
Unable to connect to the AdminServer which is running
Using WebSpeed broker
Progress Explorer can not connect to the AdminServer
CAUSE:
Broker started by AdminServer received the request to shutdown itself, but the agent was busy executing client's request therefore postponing the broker shutdown.
FIX:
End the following processes in the task manager: _progres.exe, java.exe .
If the AdminServer was started from the Control Panel -> Services and Local System Account was used, then either:
- Reboot the machine
or
- Use kill.exe from the NT option kit to kill these processes
or
- Download the 'pskill.exe' utility from http://www.sysinternals.com
and use it to kill these processes