Kbase P11029: Cannot connect to database with ODBC
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/22/2008 |
|
Status: Verified
SYMPTOM(s):
Cannot connect to database with ODBC
Error in network daemon
FACT(s) (Environment):
Progress 9.1x
Windows
CAUSE:
The Merant 3.7 SQL-89 driver had a check box to deselect, "security
required" on the Advanced Tab. This option is not in the version 9 SQL-92 driver.Progress version 9 requires a valid login to connect to the database using the ODBC driver.
FIX:
Please log in as the default dba or a user who has priveleges granted through SQL by the dba. If the dba account is not known, you can create the sysprogress account in the Data Adminstration, Security. This will force security to be defined for all users on the 4GL side of the database. Then use sysprogress to log in using ODBC.
Also, this 4GL code can be run from the Procedure Editor to determine the dba:
FOR EACH _sysdbauth:
DISPLAY
_sysdbauth._grantee
_sysdbauth._dbaacc
_sysdbauth._resacc
.
END.
FOR EACH _user:
DISPLAY
_user._userid
_user._user-name
_user._password
.
END.
Please see the SQL Security Solution 20143, "Basic Guide to Defining Progress SQL92 Database Security"
for further assistance with SQL security and errors you might encounter.