Kbase P10986: SonicMQ Adapter won't start through Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
SonicMQ 4.x
Progress 9.1x
SYMPTOM(s):
SonicMQ Adapter won't start through Progress Explorer
SonicMQ Adapter won't start from the command line with adaptman
Unable to start sonicMQ1 (8297)
CAUSE:
Files are missing from SonicMQ library directory
FIX:
First: copy the following files from the SonicMQ install directory:
sonicinstall/lib/sonic_Client.jar
sonicinstall/lib/jndi.jar
and put them in the
DLC/java/sonicMQ/lib directory.
Please note that binary mode FTP must be used to transfer the *.jar files from one machine to another.
Then make the appropriate changes for your platform:
UNIX:
Edit the $DLC/bin/java_env file and replace "client.jar" with "sonic_Client.jar" in the Progress Classpath (PROGRESSCP)
WINDOWS:
Edit the Progress Classpath (PROGRESSCP) and replace the "client.jar" with "sonic_Client.jar" in the:progress.ini file under the Java Environment section entitled "; This section defines the Java environment."
or in the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\9.1C\JAVA\PROGRESSCP