Kbase P10902: Webspeed Can Not Open Adobe Acrobat files
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/09/2008 |
|
Status: Verified
SYMPTOM(s):
Webspeed can not open Adobe Acrobat files
File is pulled directly into the browser, not Acrobat, and is shown in its raw state.
The raw file displayed in the browser does not have above lines from adobe file
Using Netscape's webserver iPlanet Enterprise version 4.1
Using NSAPI messenger
The problem does not happen with 3.1A's wsnsa.dll
The problem does not happen with cgiip messenger
The problem does happen with 3.1B and 3.1C's wsnsa.dll
FACT(s) (Environment):
UNIX
Windows
WebSpeed 3.1B
WebSpeed 3.1C
The first line for the adobe file is
%PDF-1.0
x1 0 obj
x<<
x/Type /Catalog
x/Pages 9 0 R
x/Outlines 2 0 R
x>>
xendobj
CAUSE:
Bug 20010410-031
CAUSE:
HTTP consists of a "header" followed by a "body". The delimiter between these two differs based on the Webserver being used. WebSpeed contains a check for the Webserver being used and puts in the correct delimiter for that Webserver.
However, since Netscape changed it's name to IPlanet in V4.1, this check was failing.
FIX:
The bug is fixed in 9.1D02 and 10.0A.