Kbase P10444: Error 126 on Test Connect - ODBC Merant 3.7 32-bit - wrong host or service
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1D
SYMPTOM(s):
Configuring ODBC Datasource using MERANT 3.7 32-bit Progress returns error 126 when Test Connect.
Specified Driver could not be loaded due to system error 126 Merant 3.70 32-bit Progress
On a Windows platform, error code 126 translates to "ERROR_MOD_NOT_FOUND = specified module could not be found."
Entry for MERANT version exists in the REGISTRY under:
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\MERANT (version)
Registry Driver and Setup value data portions of the registry key point to the correct location of PGPRO915.DLL and the PGPRO915S.DLL files.
Client Networking product license installed
CAUSE:
The ODBC Data source is not configured correctly. Entries are missing in the Hosts and Services files.
FIX:
Set the Host and the Service correctly
1) Control Panel -> Data Sources ODBC
2) Select the ODBC Data Source in question -> Configure -> General Tab
3) Ensure that the "Host Name" and "Port Number" are valid entries