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Kbase P10050: 778 error messsages in Appserver log file. Appserver and database reside on same machine.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/08/2004
Status: Unverified

SYMPTOM(s):

Client cannot connect to AppServer

The following errors appear in the AsBroker1.broker.log:

Error 778: Error <read/writing> socket, ret=<n>, errno=<n>. (778)

Error 778: Error reading <socket> ret=<n>, errno 0 (778)

Incomplete write when writing to server" (735)

Database abnormally terminates after the AppServer encounter errors:

Disconnecting client <number> of dead server <number>. (2526)

Disconnecting dead server <number>. (2525)

AppServer and database reside on the same system

AppServer connects to the database using the -H -S and -N network parameters

CAUSE:

The Network is encountering problems causing the connections to be severed. This is a not a Progress problem.

FIX:

This is a network problem that needs to be checked out by a qualified network engineer. This is out of the scope of Progress Technical Support.

As a workaround change the AppServer connection string to connect to the database through shared memory.