Kbase P10040: Trim agents to 0 to avoid errors 2659 and 9545
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/09/2010 |
|
Status: Verified
SYMPTOM(s):
Error running WebSpeed application
Page can not be found
Page can not be found message in browser
WebSpeed error from messenger process (6019)
Disconnect from server; database is being shutdown. (2659)
Disconnecting from database <database>, user number <usernum>. (9545)
Errors 2659 and 9545 are present within the WebSpeed server log
While database backup occurs, WebSpeed broker can not be shutdown
FACT(s) (Environment):
Database is always active when error occurs
Database was shut down but WebSpeed was not
At least 1 agent was connected to database when database was down
No database verification process can be set up within the web-disp.p file
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
If 1 agent is connected to database and database is shutdown & brought back up, the agents does not have an automatic database-reconnection mechanism. If the agent is not doing any processing, it sits in a WAIT-FOR loop waiting for a WEB-NOTIFY event (as coded in web-disp.p). Once it receives this event, and tries to process something against the database, it will then realize that the database has been disconnected, thus the reason why error 2659 and 9545 are written to the log file. This is standard and expected behavior.
FIX:
Trim the agents completely to zero, thus set the minSrvrInstance=0, instead of having minimum idle agents of 1, during quiet times. When the next connection comes, the WebSpeed agents will connect to the database.
Methods:
1. From Progress explorer, select the broker, status, details, trim agents
2. Use wtbman
wtbman -i brokername -trimagents