Kbase 81980: Não é possível fazer referencia à classe OpenEdge.Core.Assert (14631)
Autor |
  Zelindo Silvio Petri - CAT |
Acesso |
  Público |
Publicação |
  05/06/2018 |
|
Ocorrência
Ao utilizar aplicações do eSocial ou REINF que utilizam-se de conexão segura do Progress OpenEdge é retornado o erro Falha de carregamento da instancia estática. Não é possível fazer referencia à classe OpenEdge.Core.Assert (14631).
Causa
Esse incidente ocorre devido a falta de bibliotecas (.pl) no Client Progress ou entrada de Propath no arquivo .ini utilizado na sessão.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Verifique a existência das bibliotecas OpenEdge.BusinessLogic.pl, OpenEdge.Core.pl, OpenEdge.ServerAdmin no diretório gui (Windows) ou tty (Linux) do Client Progress;
2. Verifique a existência da biblioteca OpenEdge.Net.pl no diretório gui\netlib (Windows) ou tty/nelib (Linux) do Client Progress;
3. Tendo as bibliotecas acima mencionadas nos respectivos diretórios, revise o Propath do arquivo .ini para referencie as mesmas. A referência às bibliotecas deve constar até o nome do arquivo e não somente até os diretórios, conforme exemplo:
c:\dlc116\gui\OpenEdge.BusinessLogic.p,c:\dlc116\gui\OpenEdge.Core.pl,
c:\dlc116\gui\OpenEdge.ServerAdmin,c:\dlc116\gui\netlib\OpenEdge.Net.pl
4. Não inclua a referência às bibliotecas no final do arquivo de Propath. Sugere-se a inclusão logo após à referências aos programas no Propath, pois o Progress possui limitação no tamanho de caracteres do Propath e estas bibliotecas mesmo referenciadas podem não ser lidas pelo Progress;
5. Na ausência destas bibliotecas nos diretórios mencionados, verifique se as mesmas existem nos diretório src e src/netlib do Client Progress. Caso encontre nestes diretórios, efetue a copia das mesmos para a pastas mencionadas no item 1 e 2;
6. Não encontrando estas bibliotecas no Client Progress que está sendo utilizado, verifique a existência das mesmas em outras estações/servidores e copie para a estação que está recebendo o erro, respeitando os diretórios mencionados no item 1 e 2;
7. Não encontrando as bibliotecas em seu ambiente, clique no link no final desta linha para efetuar download das mesmas nas versões 11.5, 11.6 e 11.7: Bibliotecas (.pl) para Client Progress.
Artigo KCS:
https://centraldeatendimento.totvs.com/hc/pt-br/articles/360004550711