Kbase 35877: Error 5814 occurs on the first WebSpeed request
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/10/1998 |
|
Solution ID: P5877
FACT(s) (Environment):
WebSpeed 3.x
SYMPTOM(s):
Error 5814 occurs on the first WebSpeed request
WebSpeed error: Msngr: Disconnecting with no header on WTA output web stream. <BR> (5814)
The web server and the WebSpeed Transaction Server is in the same machine.
Database is shutdown every night without stopping the WebSpeed broker
CAUSE:
The database is shutdown without stopping the broker.
This is expected behavior if the database is being shutdown without the broker being shutdown first or trim all WebSpeed agents from the broker. When the database is shutdown, the client is NOT informed about the database shutdown when the connection is a client-server one (with -S and -H). Therefore, after the database is broad backup, the WebSpeed agents do not know about it. If the agent is not doing any processing, it sits in a WAIT-FOR loop waiting for a WEB-NOTIFY event (as coded in web-disp.p). So the next time the Webspeed agent or a Progress client tries to access the database in any form (even trying to find out if the database is connected or not), a socket error will be generated, and that is the reason why the first attempt fails, and the WebSpeed messenger displays the error 5814 in the browser. With the second request, the client recognizes that the database as not been connected, and the web dispatcher than tries to connect to the database and the error goes way.
If you have multiple agents connected to the database in the same scenario, error 5814 will be displayed for each agent connected.
FIX:
There are a couple of things to correct the situation:
1. Stop the broker before stopping the database for maintenance purpose and restart the broker after the database is successfully started.
or
2. Trim the agents from the broker before the database maintenance.
You can also modify the default error message for error 5814 in Webspeed 3.1C or higher with a customized message or a customized web page so the end user can get a user friendly message or a page. Follow the solution on how to customize the error message for the WebSpeed messenger: 18841, "Customize WebSpeed Messenger Errors"