Kbase 34709: Connect via Progress Explorer to AdminServer generate Invalid username and/or password specification. (9173) error.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/05/1998 |
|
Solution ID: P4709
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
Progress 9.1D
SYMPTOM(s):
Invalid username and/or password specification. (9173)
Connection via Progress Explorer to remote AdminServer fails with valid login and password.
Security Features not enabled during installation
Cannot connect from Progress Explorer to AdminServer
AdminServer is up and running
CAUSE:
User starting the AdminServer is missing several OS User Rights and Privileges.
Some of the Rights and Privileges are:
- member of local Administrator group,
- Log on as a service,
- Log on as batch job,
- Act as part of the operating system,
- Increase quotas,
- Create a token object,
- Replace a process level token.
FIX:
For Windows NT :
1) From Start - Administration - User Manager, select Policies -
select User Rights menu
2) Check the option "Show Advanced User Rights"
3) From "Right" option, Select the option : "Log on as a batch job"
4) Click on "Add" button
5) Select your NT DOMAIN from "List Names From "
6) Click on "Show Users"
7) Select the USER and click on Add button
8) From "Right" option, select "Log on as a service"
9) Re-do steps from 4 to 7 to add the other rights
For Windows 2000 :
1) Go to Control Panel -> Administrative Tools -> Local Security Policy
2) From left pane choose Local Policy -> User Rights Assignment
In the right panel you have to find following Policies:
- Log on as a service.
- Log on as batch job.
- Act as part of the operating system.
- Increase quotas.
- Create a token object.
- Replace a process level token.
3) Double-click on each one of the policies stated in the
previous step and add the user account that you wish to be able to
connect via Progress Explorer to the AdminServer
These changes require a logout prior to taking effect.