Consultor Eletrônico



Kbase 34549: How to recover from error 606
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/05/1998
Solution ID: P4549

FACT(s) (Environment):

Progress 8.x

SYMPTOM(s):

Extent <file-name> has a different last opened date. (606)

Probable backup/restore error. (605)

Database is damaged, see documentation. (1486)

The database was last used <date/time>. (886)

The before-image file expected <date/time>. (887)

Those dates don't match, so you have the wrong copy of one of them. (888)

CAUSE:

If system utilities are used for backing up the database, it can happen that mistakes are made in which files are backed up, or mistakes can be made when a restore of such files is done: files from different dates and different states of the database can get mixed up, for example.

FIX:

If at all possible, go to backup and apply the AI files to bring the database back to the latest position. If this isn't an option, then:

1. Before going any further, backup the database. Ensure that all database files are backed up.

2. Read the relevant documentation on the dangers of using the -F to force into the database.

3. prostrct unlock <dbname>

This should resolve the 606. Now:

4. Try to start the database in single-user mode. Most likely, however, you will get the 886, 887, 888 errors, so you will have to force into the database. Thus:

5. proutil <dbname> -C truncate bi -F

6. Try to start the database in single-user again. The database should start, but the warning will be returned that the database was damaged, and you will need to do a dump and load as soon as possible.