Kbase 34218: Report Engine Cannot Connect to Database After Installation Via NetSetup
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/10/1998 |
|
Solution ID: P4218
FACT(s) (Environment):
Progress 9.1x
Windows NT 32 Intel/Windows 2000
SYMPTOM(s):
Installed Report Builder and Client Networking via NetSetup
The report engine will not connect to any database
Report Builder has detected that the SQL engine has shut down due to a database error
CAUSE:
This problem is caused by doing an installation into a 'root' directory location (e.g. C:\, F:\, Z:\)
FIX:
To resolve this problem, do the following:
1) Map the drive and make sure it is the whole directory (e.g. V:\Progress instead of just V:\) so that it correctly points to the D:\progress directory on the server, which is the Local progress DLC directory from which the Netsetups are done. Do not use the drives root directory.
2) Set PROCONV and PROCFG environment variables so that the directory mapped to is not the root directory on the server.
The PROCONV environment variable can be set in the registry. Use the following steps to do this:
A) Click the Windows 'Start' menu (bottom left of the screen)
B) Click the 'Run...' icon
C) Type 'regedit' in the Run dialog that will appear
D) Click the 'OK' button
E) In the RegEdit utility, navigate to the following key:
(replace '9.1x' with the version of Progress that is installed)
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\9.1x\Startup
F) Select 'Edit' from the menu bar
G) Select 'New' from the 'Edit' menu
H) Select 'String Value' from the 'New' menu item
I) Select the menu option Edit -> 'New' -> String Value
J) Type 'PROCFG' into the 'Name' field
K) Type '<NetworkDrive>:\PROGRESS.CFG' into the 'Data' field
(replace <NetworkDrive> with the actual network drive letter)
L) Repeat steps F, G and H
M) Type 'PROCONV' into the 'Name' field
N) Type '<NetworkDrive>:\CONVMAP.CP' into the 'Data' field
(replace <NetworkDrive> with the actual network drive letter)
</blockquote