Consultor Eletrônico



Kbase 33438: ProControl: Cannot Find Lock (.lk) file. See EVENT VIEWER
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/05/1998
Solution ID: P3438

FACT(s) (Environment):

Windows 32 Intel
Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

Cannot Find Lock (.lk) file. See EVENT VIEWER

Using ProControl to start database.

ProService is started with the System Account.

Database on a NTFS partition.

CAUSE:

The user account that starts the database needs to have a minimum of read and write permissions on the folder and files of the database. In this case it is the account that is used to start the ProService service.

FIX:

Check permission of the folder and files where Progress databases are installed. By default NTFS drives are set to allow Everyone Full Control. If the drive permissions were altered, then the database files may not be accessed through ProControl (although they will start up via proenv).