Kbase 21599: MERANT: No SQL Schema Found in Database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1x
SYMPTOM(s):
Error running when connecting with the SQL-92 ODBC Driver.
[MERANT][ODBC PROGRESS DRIVER][PROGRESS]No SQL Schema found in database (run mkschema).
CAUSE:
The database lacks SQL-92 Schema. Either it failed during conv89 or a previous install of Progress 9.1x did not support SQL-92. Therefore the SQL-92 schema was not created.
FIX:
To establish SQL-92 access to the database, perform the following steps:
1) Shutdown the database.
2) Backup the database and verify the backup.
3) Run the mkschema as follows:
mkschema -v database-name.
Since the ODBC driver which comes with most Progress 9.1X products uses SQL-92 access, the database should be allowed to have this access. Therefore if the database was not planned for SQL-92 access, the MKSCHEMA utility must be run. MKSCHEMA is only provided with the 4GL and ProVision licenses, and it is only installed on the system when a complete install is done.