Consultor Eletrônico



Kbase 21417: Report Builder: Error: Cannot Open Library File
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/5/2010
Status: Unverified

SYMPTOM(s):

Report Builder: Error: Cannot Open Library File

Error: Cannot open library file <LibraryName.prl>

Printing a report Builder report

The report prints, but you have to press the OK button to get rid of the error and continue the printout.

FACT(s) (Environment):

All Supported Operating Systems
Progress 8.x
Progress 9.x

CAUSE:

The problem occurs in situations where the report has been deployed over a Network and the DLC environment variable is pointing to a Remote Mapped drive -- for example, in the progress.ini file of the client: DLC=P:\DLC.

FIX:

In your client session you will have to point to the local DLC directory of the client.

For example, if your local DLC directory is:

D:\DLC

the value of DLC in the progress.ini file, change it to:

DLC=D:\DLC