Consultor Eletrônico



Kbase 21343: Progress/400 DataServer Installation Error
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/09/2004
Status: Verified

FACT(s) (Environment):

Progress/400 DataServer

FACT(s) (Environment):

IBM AS/400 (RISC)

SYMPTOM(s):

If there is a previous installation of the Progress/400 DataServer, and user tries to install a newer version, or even the same version of Progress/400, the error message will occur after "LODRUN DEV(OPT01)" is executed

ERROR:"This program cannot be called directly press ENTER to end terminal session"

Installation terminates.

CAUSE:

During the installation of the Progress/400 DataServer, the installation utility checks the user library list in AS/400. If it finds the Progress system library, it looks at existing programs in the AS/400 machine instead of the installation media in order to install the product.

FIX:

Delete the Progress system library from the library list before installing the product.
Steps to follow before the installation:

1) Check the user(QSECOFR) library list using the following command:

DSPLIBL

2) If the library contains *progress* as a system library, then delete
it using the following command:

CHGSYSLIBL

You will be prompted with this screen:

Change System Library List (CHGSYSLIBL)

Type choices, press Enter.

Library . . . . . . . . . . . . progress Name
Option . . . . . . . . . . . . . *remove *ADD, *REMOV

This will remove the Progress system library.

3) Now, install the Progress/400 DataServer product using this
command:

LODRUN DEV(OPT01)

The product should install successfully.