Consultor Eletrônico



Kbase 21331: 9.1x - Adminserver fails to start from proenv or command line but will start from Windows Services
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Unverified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

proadsv -query -port indicates the AdminServer is not alive

Failed connecting to AdminServer. Verify it is running. (8546)

proadsv -start -port returns without errors.

AdminServer can be started and stopped from the Windows AdminServer Service


Can connection to Progress Explorer after the AdminServer was started from Windows Services

Stop AdminServer from the command line failed with these message:


Other command line utilities that depend on AdminServer failed to start, for instance Fathom.


Exception in thread "main" java.lang.NoClassDefFoundError: com/progress/isq/ipqo
s/admin/cli/FathomMan
Error parsing file to execute: (c:\progross_91c\jre\bin\java)
Error starting JVM, error 1.
Incorrect function.

CAUSE:

Necessary JAVA environment variables were not set at the operating system level. Windows only sets the JREHOME or/and JDKHOME environment variables. Variables JDKCP and JRECP need to be set.

The GUI interface for AdminServer looks in the registry for environment information. The command line utility, proadsv, looks in both the manual environment and the registry depending on if JREHOME was set up. If JREHOME is set (with or without other Java environment settings), Progress takes all of the Java environment from the system environment. If the additional environment variables have not been set the error occurs. If there is no JREHOME is set, Progress will switch to the registry for information.

FIX:

Avoid setting any Java environment variables from Windows. Let the registry take care of the environment instead.

- or -

Set all the Java environment variables manually.