Consultor Eletrônico



Kbase 21299: System Error (5543) During Crash Recovery or BI Truncation
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/14/2006
Status: Unverified

SYMPTOM(s):

Truncate of BI file fails.

Crash recovery fails to complete

SYSTEM ERROR: rmundochg: size <rec-size>, expected <rec-size> (5543)

CAUSE:

The error indicates that Progress was unable to undo a change made to a record. Progress could not undo the change because the BI note required for the undo indicated a record of one size and the record that needed to be undone reported a different size. Progress writes the size value of the record before a change and after a change (different values) to a note within the BI file. During the undo phase these size values are verified. When the sizes do not match Progress generates the error. This error simply states that the size values were not the same and that Progress could not undo the change(s) made to the record in question.

A size difference can be caused by any number of factors, and these circumstances are not further defined in the error message other than the fact that the two sizes are shown. As a result this could indicate that there is a problem with either the BI file or the record itself.

So the error message can indicate either database corruption or BI file corruption, but it's not specific.

Reasons why the undo may fail:

a) User(s) incorrectly logging out of the database. If this particular case occurs check the database log to verify if any improper logout occurred. After the improper logouts when a database shutdown is initiated, microtransactions that did not complete properly may leave a corrupt BI note(s). As a result the microtransaction(s) that could not be backed out of the database during the shut down, cause the error.

b) The BI file has exceeded the 2GB limit.

c) The partition that contains the BI file is not large enough to accommodate the growth of the BI file.

d) One, some, or all the BI extent(s) is/are on a questionable or failed disk or disk sub-system.

e) The BI file was written by a corrupted disk write cache.

FIX:

1. Make an OS copy of all the files of the failing database

2. Restore the database from a verified,known good backup, or

If the database can not be recovered from a restore, do the following:

1. Force into the database by running proutil dbname -C truncate bi -F

2. Run proutil dbrpr utility to scan the database

3. Clean up any bad records or/and blocks

4. Do an idxbuild, if any blocks/records are removed

5. Do a dump and load of the database followed by an idxbuild.