Kbase 21291: AppServer Agents Fail To Start on SCO OpenServer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/11/2008 |
|
Status: Verified
FACT(s) (Environment):
SCO OpenServer
SYMPTOM(s):
AppServer agents failing to start on SCO OpenServer
ERROR: cannot start server. (8100)
Server exec error : <IOException_string> <IOExceptionMsg_string> (8109)
CAUSE:
For example -- assume 10 AppServer Agents have been specified to autostart for the AppServer broker. A query of the AppServer broker shows:
PID State Port nRq nRcvd nSent Started
06135 CONNECTED 04000 000001 000001 000001 09-Aug-01 01:26
06136 CONNECTED 04001 000001 000001 000001 09-Aug-01 01:26
06137 CONNECTED 04002 000001 000001 000001 09-Aug-01 01:26
06138 CONNECTED 04003 000001 000001 000001 09-Aug-01 01:26
06139 CONNECTED 04004 000001 000001 000001 09-Aug-01 01:26
06318 CONNECTED 04005 000001 000001 000001 09-Aug-01 01:35
When a seventh user attempts to connect, the connection fails with the errors displayed in the AppServer broker.log file.
Only 6 AppServer Agents are spawned out of the 10 specified due to a kernel limitation on SCO.
SCO OpenServer has a limitation relative to the number of TCP connections that can be made to that machine.
To verify this as the cause of the problem, attempt a telnet connection to the machine. If the telnet fails the problem is the result of the limitation.
FIX:
The following steps will permit more connections to the machine, which will in turn enable the AppServer to spawn more agents.
1. Start scoadmin
2. Choose Networks > Network Configuration Manager > 'Network Adapter'/SCO TCP/IP > Modify Protocol Configuration > TCP Connections.
This setting has a default value of 256; meaning that only a total of 256 TCP connections can be established. Increase this setting then rebuild the kernel.