Consultor Eletrônico



Kbase 21256: Webclient 9.1C: 'Open With' Screen for the prowcapp File
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   22/12/2006
Status: Unverified

SYMPTOM(s):

Getting 'Open With' or 'Save As' dialog box for prowcapp file when trying install or run WebClient application.

CAUSE:

Shared files not deleted in the uninstall process of WebClient. It can also happen after an unsuccessful uninstall which might have left behind some files.
When uninstalling WebClient, there is a prompt to delete or keep some shared files (proWCVer.dll, prowcini.exe, PSCSecReg.dll and prowcam.exe). If these are kepts, the install process will detect that the files are there and assume WebClient is already installed and try to open the prowcapp file, but it will fail and the 'Open With' screen will appear.

Also, if during any previous WebClient uninstall process the 'Don't display this message again' toggle-box is checked and answered NO, these files will not be deleted the next time the WebClient is uninstalled.

FIX:

1) Manually delete the file named proWCVer.dll or any other files left behind) located under C:\Program Files\Common Files\Progress Software\WebClient.
Then reinstall WebClient and the application should start.

Make sure to answer YES to delete the shared files when uninstalling WebClient the next time, especially proWCVer.dll, to avoid this problem happening again.
2) If the 'Don't display this message again' option is checked, delete any references to these WebClient files from the Windows Registry so that the messages will display again:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs]

Then delete the entries that reference DLLs located under:

C:\Program Files\Common Files\Progress Software\WebClient