Kbase 21189: Error 8084, EOFException, is displayed during Verbose Logging?
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/12/2009 |
|
Status: Verified
SYMPTOM(s):
EOFException received on client connection : <threadName>. (8084)
When Verbose logging is enabled for AppServer and WebSpeed, it is common to see error 8084
Error 8084 may also be seen within the DataServer (ORACLE, MSS, ODBC) log files when using the Unified Broker.
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
The EOFException occurs when a client program disconnects from the Unified Broker. It is logged in Verbose logging mode only, simply to document when a particular connection has been terminated, just as each client connection is logged.
The EOFException means that the Unified Broker tried to read a message from the client and got an "End of File" (EOF) indicating that there is no more information to be read from the input.
For Socket input, this means that the connection has been disconnected. The term "EOFException" is a standard JAVA description of this situation.
Termination of a client socket connection is a part of normal AppServer operations.
FIX:
The appearance of this message in the log file is Not an indication of a problem.
The presence of these exception messages in the log file is normal when using verbose logging.