Consultor Eletrônico



Kbase 20958: Error when trying to generate reports via the Actuate Report Server: Request not Submitted
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Unverified

FACT(s) (Environment):

Actuate e.Report Server 4.x
Actuate e.Report Server 5.x

SYMPTOM(s):

The following error message appears when attempting to generate reports via the Actuate Report
Server: Request not Submitted.


The error can happen with either a scheduled or a user-generated report request.

ACDEFRAG could also fail.

CAUSE:

The issue is most likely caused by data corruption in the Actuate Encyclopedia structure files, The .DAT files, and particularly the completed_requests_table file.
 
The problem also occurs if the there is data corruption in the /Actuate/server/requests/highest.DAT file.
 
Data corruption can be caused by many things, some of which are listed but this is in no way a conclusive list.

- Access or manipulation of the OS level files while they are locked and in use by the server.
- Physical disk problems.
- A dirty shutdown of the server, etc....
 

FIX:

There are various workarounds you can try. Follow the next steps:

Backup the Actuate Encyclopedia.
Shut down all the Report server processes (Persistent Object, AdminServer and Request Server).
Delete all the files in the /Actuate/server/requests folder.
Re-Boot and restart the Actuate Processes.
A second workaround is to try to regenerate the highest.DAT file by running the report/s to produce the ROI file in a different folder.
 
As an alternative, delete the highest .DAT file. 
 
Anyway keep in mind that the Report Encyclopedia could be led in a unknown state. The real recommended approach should be always:

Restore from a previous valid backup or
"Clean up" the encyclopedia and reload it with AcExport/AcImport approach