Consultor Eletrônico



Kbase 20946: Actuate: Unable to Delete a User Folder in the Encyclopedia
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Unverified

FACT(s) (Environment):

Actuate 4.0
Actuate 5.0

SYMPTOM(s):

When you try to delete a user's personal folder from a Report Server Encyclopedia, you might receive the following error message:
<NAME-OF-THE-SERVER>:__AC_PERSISTENT_OBJECT_SER VER_4 object already write locked.

You are logged in as the owner of the folder or as the Administrator.

The error appears even if the folder privileges have been set correctly or to ALL.

Actuate Administrator Desktop.

End User Desktop.

CAUSE:

The message occurs because the report server lock files were not deleted properly.

FIX:

 
To rectify the situation follow these steps:

Shutdown the report server.

Delete the lock files from your <drive>/Actuate4/Server/tmp directory.
Restart the report server.
Shutdown the report server.

Delete the Completed_request_status_2.dat file that is located in the <drive>/Actuate4/Server/request directory.
Delete the Request_status_table_2.dat file that is located in the <drive>/Actuate4/Server/request directory.
Restart the report server.
NOTE: Deleting both the files in step 2 deletes all completed notices for all users.