Kbase 20945: Errors 9215, 9213, 9217, 605, 1486, 606 after Restoring from 3rd Party Backup Software
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/16/2008 |
|
Status: Verified
SYMPTOM(s):
Errors 9215, 9213, 605, 1486 after Restoring from 3rd Party Backup Software
Last open date mismatch. (9215)
Extent <file-name> has a different last opened date <timestamp>, (9213)
Control Area has a last open date of <time-stamp>. (9217)
Probable backup/restore error. (605)
Database is damaged, see documentation. (1486)
Extent <file-name> has a different last opened date. (606)
Removed shared memory with segment_id:
FACT(s) (Environment):
Third Party backup utility was used to backed up the database while online
Progress/OpenEdge Versions
All Supported Operating Systems
CAUSE:
When a 3rd party backup utility is used to backup the database files one by one, there is a time difference between the .DB, D1 and the BI files. This is occurs because the before-image (BI) subsystem continues to keep track of it's internal time while the database is online.
Although the backup and restore appears to have been completed successful, the files were backed up with different time stamps between the files and have become "out of sync" with each other.
After a restore of the database files that were backed up "out-of sync", Progress detects the timestamp difference and produces the above-mentioned errors.
FIX:
Progress advises the use of the PROBACKUP utility for backing up the Progress database because PROBACKUP backs up all the database files on-line in the same state (with the same date/time stamp) by making a snapshot of the database.
If no users where accessing the database while it was backup online the "PROSTRCT UNLOCK" command can be used to synchronize the database files with little risk of corrupting the database.
If the database was online and in use, it is likely that the database has been corrupted. Only PROBACKUP can make a correct backup of an online database.