Kbase 20710: Error 495 occurs when accessing Progress application with only runtime license
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/01/2011 |
|
Status: Verified
SYMPTOM(s):
Error 495 occurs when accessing Progress application
** This version of PROGRESS requires a start up procedure. (495)
Only 'runtime' license is installed
Runtime license i.e., Client Networking, DataServer licenses
FACT(s) (Environment):
Progress/OpenEdge Product Family
All Supported Operating Systems
CAUSE:
By default Progress starts up the 'Progress procedure editor' when invoking prowin32 and/or _progres client. With a runtime client, this menu (procedure editor) along with other menus, such as Data Dictionary and Data Administration are not available. You are running a version of PROGRESS that does not contain the Procedure Editor and the Compiler, so you must start the session with a precompiled program. This is expected behavior.
FIX:
In order to access these menus, use the -rx startup parameter
prowin32 dbname -rx
_progres dbname -rx
All other startup parameters can be added after the -rx.