Kbase 20644: Error 5191 and 8850 occurs when trying to start a database from Progress Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/16/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.x
SYMPTOM(s):
Getting errors when trying to start database from Progress Explorer tool
Error: Unable to find protocol TCP in file PROTOCOL or PROTOCOL file not found in expected location. (5191)
Unrecoverable error in connection to Admin Server, running unmanaged. (8850)
Both errors present within database.log file
No service name nor port number defined when trying to start broker from Progress Explorer
Database can be started with proserve command on command line
CAUSE:
When trying to start a database broker from Progress Explorer with no associated service name nor port number, the default value for the -S parameter is zero (-S 0). This port, "0" is invalid. It is not possible to start a database broker using the Progress Explorer Tool for local users only. The database broker always attempts to connect to a TCP port.
FIX:
Specify a valid port number or service name for the database from Progress Explorer tool. Go under defaultServerGroup and specify the port or the service name. Ensure that your services file has been configured correctly when using a service name.