Kbase 20504: Progress (1149) Error with Progress 9.1A on AIX
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/10/2008 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.1A
SYMPTOM(s):
SYSTEM ERROR: ncsbuf
ssbuf rmallocdll out of memory for message buffers (1149)
It is possible to get a Progress (1149) error when you run a lengthy report in the client server mode of operation, yet when you run the same report as a self service client the report operates normally and correctly.
CAUSE:
The (1149) error indicates that the system has encountered problems managing memory.
The rmallocdll routine is a routine that sizes memory and attempts to manage the throughput from the client to the server over the network. This routine is used in the client server mode of operation but is not used in the self service client mode of operation.
In the case of the (1149), the system has sized the memory up and determined that it does not have enough available buffer space to transmit messages out over the network to the client. A typical cause is that the amount of memory required to hold information exceeds the limits of the available memory for the particular client connection.
FIX:
As a workaround:
- Try to reduce the scope of the report.
- Try to limit the number of records requested by the report.
- Run the report several times with different record scopes.
You could make a self-service connection for the duration of the report. However, if the report fails, there is a chance you might have to manually disconnect the client and kill the report process.