Consultor Eletrônico



Kbase 20444: Client hangs when run from a SCO OpenServer machine connecting to a Progress AppServer broker.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/30/2008
Status: Verified

FACT(s) (Environment):

Progress 9.x
SCO OpenServer

SYMPTOM(s):

Client hangs with Java errors when connecting to a Progress AppServer broker.

Error occurs when running application:

ERROR: CSOPTTABNREQUEST: protocol error

ERROR: Communication layer message: <message text>. (7175)

ERROR: Client Communications Failure - <Java Exception> (8409)

Open4gl protocol mismatch. Server version is <version#>. Client version is <version#>. (8111)

Client server version mismatch. Client <version#>. Server <version#>. (8112)

The Java client generates:

com.Progress.open4gl.Open4GLException:
Communication layer message:
Client Communications Failure - java.net.SocketException:
Socket read failed (8409). (7175)

CAUSE:

The problem with the client AppServer connection is caused by a failure in the SCO OpenServer "binary compatibility mode".

Starting with version 9.0B, Progress has only one port to cover all UnixWare and SCO OpenServer platforms. In order to run on the SCO OpenServer, the OSRCompat Binary Compatibility Module (BCM) must be installed (as referenced In the Installation Guide).

FIX:

Download Patch OSS630; (OpenServer 5 UDK Socket Supplement for OpenServer 5.0.4 - 5.0.6) from the SCO website to fix the problem: (ftp://ftp.sco.com/pub/openserver5/oss630a).
Please contact SCO if you have problems applying the patch.