Kbase 20412: License Update / Product Update fails to add an additional product, update user count, or update eva
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  06/05/2010 |
|
Status: Verified
SYMPTOM(s):
Product Update fails to add an additional product, install serial number with updated user count, or update evaluation copy
License Update fails to add an additional product, install serial number update user count, or update evaluation copy
Error installing Progress license to existing installation
Error Updating user count to Progress installation
Error upgrading from evaluation license to commercial license
Error 146 using the Progress Update Utility on UNIX
INSTALLATION ERROR (146): Serial number did not match
INSTALLATION ERROR (133): Product not installed. Unable to update product
Error using the License Update Utility on Windows
Installation Error "Serial Number did not match" running License Update
Error in serial or control numbers. Product not installed. Unable to update product list.
The installation utility has detected that you have entered duplicate product information.
New License has different serial number than the original installation
FACT(s) (Environment):
All Supported Operating Systems
Progress 7.x
Progress 8.x
Progress 9.x
OpenEdge 10.0x
OpenEdge 10.1A
Fathom Versions
WebSpeed Versions
CAUSE:
The PROUPDATE / License Update utility can not be used to install a new product, upgrade an evaluation release or increase the user count using a serial number that is different from the installed serial number. The serial number installed must be the same as the serial numbers for the already installed products.
For Evaluation copies, internal shipment procedures causes the serial number for the commercial release to be different from the evaluation release preventing the users to use the License Update application.
The newly created control codes must be generated against the existing installation's serial number.
FIX:
To add additional Products to an existing installation:
Add additional product(s) to an installation by using the original installation utility (setup.exe from the Installation CD on Windows and proinst on UNIX). Select the option to: "Install the Progress products in the pre-existing destination path" and choose the existing installation as the installation path.
This will update the Progress.cfg file with the new packages. Be aware that it is necessary to shutdown all the Progress processes before replacing this file.
To update an Evaluation Copy to a Commercial release:
To update an Evaluation installation with the commercial release it is necessary to uninstall the evaluation copy and re-install it with the new set of serial numbers and control codes provided.
Another workaround for this situation is run a Progress installation on another system to obtain the newly generated progress.CFG file and replace it on the evaluation installation. Be aware that it is necessary to shutdown all the Progress processes before replacing the file.
To increase the User count:
The Progress Update and License Update utility is used to change the number of users and the expiration date for a Progress product that is installed.
Thus, the serial numbers used to update the number of users and/or expiration date must match. In order to increase the user count of an already installed Progress product, the new serial number has to be the same as the serial number of the product already installed.
Ensure that the Progress control codes are generated against the same serial number that the customer currently has installed. If not the product update will fail and an uninstall/install must be done.
To avoid a reinstall, install the required license on another system of the same Operating System. Backup the existing progress.cfg file and place the new Progress.cfg file into the $DLC directory.
In the case of WebSpeed Transaction Server, when you go from a 5 or 25 user count that is found on the basic server to a 50 or 250 user count there is a change in the product to the enterprise version. The only way to get this increase in the user count is to install the enterprise product as a separate product being added to the existing installation, since it is considered a different product at installation time.
For OpenEdge 10.1B and later, please refer to Solution P126172, "Can I run proupdt with different serial numbers in 10.1B?"