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Kbase 20392: Troubleshooting System Error (9147)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

Progress 9.x

SYMPTOM(s):

Progress Explorer returns fails to retrieve status info

Error: No data received, awaiting Registration ACK. (9147)

CAUSE:

The (9147) error message is generated from a module of code called nschkcomsoc. This module checks TCP/IP communication and grabs any messages that may be waiting. The following text appears in the comments section of the module:

PROGRAM: nschkcomsoc -- Test TCP/IP connection to the Admin Service and read any messages. Both the initial connection and any reconnects are handled in this function. This is also the main dispatcher for receiving messages, taking any requested action (shutdown), and sending both response (BIW is running, etc.) and async (Abnormal shutdown) messages.

returns: 0 - OK, non 0 - errmsg printed


The appearance of Error (9147) indicates that the broker has tried to contact the AdminServer at least 10 times and has failed to establish the connection. Logical reasons for not being able to establish the connection are:

- The TCP/IP socket is not the same between the AdminServer,
Nameserver and database.

- There is a network problem.

- The AdminServer is too busy to respond.

- The services files between the systems are different.

- The AdminServer is down.

FIX:

When you troubleshoot Error (9147) on Windows NT systems:
- Start Progress Explorer and connect to the Adminserver. Once connected, it would verify that the Adminserver is running.

- Check to see if you can communicate on the network by using a
network test utility such as ping, traceroute, telnet (using
the port numbers for the AdminServer).

- If the AdminServer is running, how many databases are being
run?

Could you be over extending system resources and causing the
AdminServer to be too busy to respond?

- Check the services files of the machines concerned and verify
that the entries that the AdminServer is using are absolutely
identical on all the machines.

On UNIX machines, verify that the AdminServer is running by using a process status (ps).