Consultor Eletrônico



Kbase 20257: Error 8336 occurs when using different versions of Progress Explorer and AdminServer
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/2/2009
Status: Verified

SYMPTOM(s):

Error attempting to connect from the Progress Explorer to a Progress AdminServer

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

Can ping AdminServer machine successfully.

Can telnet to the AdminServer port

"proadsv -query" against the AdminServer on remote machine returns status "alive"

AdminServer is alive. (8545)

Error (8336) occurs when connecting via Progress Explorer

The progress.cfg file is present and correct

The PROCFG environment variable is not pointing to the wrong progress.cfg file

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x
All Supported Operating Systems

CAUSE:

Configuration with different versions or patched levels of Progress Explorer and AdminServer is not supported.

The problem is typically seen when the AdminServer is started with one version of Progress (say 10.1B), then try to connect from the Progress Explorer which is using another Progress version (say 10.0A). This configuration is invalid. The Progress AdminServer version and Windows Progress Explorer version must be the exactly the same.

FIX:

If the AdminServer and the Progress Explorer versions are not the same, one or the other need to be upgraded/downgraded so that their versions match exactly (including patch/service pack level).