Kbase 20214: Registry Keys for AdminServer/JAVA Not Installed for Progress 9.x
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  21/08/2003 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.1x
Windows NT 32 Intel/Windows 2000
SYMPTOM(s):
Cannot connect to the AdminServer via Progress Explorer
CHANGE:
Installation of 9.1B
CAUSE:
AdminService entry is not added to the Windows NT services.
The command admsrvc /install shows the following result:
AdminService9.1B installed.
AdminService9.1B started.
But after a reinstall of the AdminService, there still is no connection to to the AdminServer via Progress Explorer.
Further investigation shows that the Registry entry for the AdminService Startup Command is missing the following entry:
Key: My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > PSC >
AdminService > 9.1B > StartupCmd
String Name: Chimera
String Data: "d:\dlc91b\bin\jvmstart" -o eventmgr -w
@{WorkPath} -c
@{JAVA\JRECP} "C:\WINNT40\jview.exe" /cp
@{JAVA\PROGRESSCP} /d:Install.Dir=@{Startup\DLC}
/d:Work.Dir=@{WorkPath}
/d:jvmstart.debug=0
com.progress.chimera.adminserver.AdminServer
NOTE: In other cases, Progress engineers have seen that the entire JAVA Registry key is missing. This is seen in Version 9.1A:
Key: My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > PSC >
PROGRESS > 9.1B > JAVA
String Name: JDKCP
String Data: d:\dlc91b\jdk\lib\classes.zip
String Name: JDKHOME
String Data: d:\dlc91b\jdk
String Name: JRECP
String Data: d:\dlc91b\jre\lib\rt.jar;d:\dlc91b\jre\lib\i18n.jar
String Name: JREHOME
String Data: d:\dlc91b\jre
String Name: JVMARGS
String Data: -ms1m
String Name: JVMEXE
String Data: jre
String Name: PROGRESSCP
String Data: d:\dlc91b\java\progress.zip
In addition, the Shutdown command is missing the Chimera entry as well:
Key: My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > PSC >
AdminService > 9.1B > ShutdownCmd
String Name: Chimera
String Data: "d:\dlc91b\bin\jvmstart" -o eventmgr -w
@{WorkPath} -c
@{JAVA\JRECP} "C:\WINNT40\jview.exe" /cp
@{JAVA\PROGRESSCP} /d:Install.Dir=@{Startup\DLC}
/d:Work.Dir=@{WorkPath}
com.progress.chimera.adminserver.AdminServerShutdown - service
FIX:
1) Run admsrvc /install.
2) Manually add the entries into the Registry.
3) Reinstall Progress.
A reinstallation of Progress almost always fixes this problem.