Consultor Eletrônico



Kbase 20205: Error 8336 When Connecting to the AdminServer Windows 2000
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

Windows 2000

SYMPTOM(s):

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

CAUSE:

Dynamic Host Configuration Protocol (DHCP) allows dynamic assignment of IP addresses. The network administrator manually configures only one machine, the DHCP server. Whenever a new machine, (the DHCP client), is plugged into the network segment that is served by the DHCP server, the machine asks for a unique IP address and the DHCP server assigns it one from the pool of available IP addresses.

To make sure addresses are not wasted, the DHCP server places an administrator-defined time limit on the address assignment, called a lease. Halfway through the lease period, the DHCP client requests a lease renewal and the DHCP server extends the lease.

This means that when a machine stops using its assigned IP address (for example, on being moved to another network segment or being retired), the lease expires, and the address is returned to the pool for reassignment. When a machine is unable to reach a DHCP server at startup in windows versions prior to Windows 2000, it will continue to use the currently leased DHCP address until the lease expires.

Windows 2000 behaves differently. Some Windows 2000 machines, when using DHCP, lose connectivity to all local network resources if they are unable to reach a DHCP server at startup. Without local networking resources, this client cannot connect to the Progress AdminServer and you see the above error message. This is due to a new feature of the DHCP client for Windows 2000 called Automatic Client Configuration. The feature allows the client to use Automatic Private IP Addressing (APIPA) to automatically configure an IP address and subnet mask when the client is started where there is no DHCP server is available to assign addresses.

FIX:

This is a Microsoft issue and further information and workarounds can be found at www.support.microsoft.com, Articles Q255836 and Q244268.