Kbase 20171: "Proshell dll Registerserver" Error During Installation
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  08/05/2009 |
|
Status: Verified
SYMPTOM(s):
Installation of client networking product receives an error regarding promsgs file.
Alert error is received when installing new version of Progress.
Alert: proshell dll registerserver: cannot find promsgs file >c:\dlc.
PROSHELL Error installing Progress:DLLRegisterServer: Can not find PROMSGS file
<C:\Program Files\Progress\PROMSGS>
PROMSGS is set in the system environment variables.
FACT(s) (Environment):
Machine where installation is being performed either has an existing installation of the same or different version of Progress/OpenEdge or had an installation that was recently removed/uninstalled.
Windows
Progress 8.x
Progress 9.x
OpenEdge 10.x
CAUSE:
System Environment Variables exist that are pointing to either a different or previous installation of Progress/OpenEdge.
FIX:
Remove all System Level environment variables for Progress/OpenEdge that are pointing to a different or previous installation of Progress that exist in
Control Panel -> System Properties -> Environment. Then, run the installation again.