Kbase 20099: Connection from App server client to the app server is slow - caused by misconfigured DNS
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/26/2010 |
|
Status: Verified
SYMPTOM(s):
CONNECT() method on the AppServer handle is slow
The connection will sometimes takes a minute or two to establish
TCP/IP is configured to use DNS
The client's IP address appears in the ConnectionID reported in the AppServer log files, rather than the name of the workstation.
Running nslookup from the server machine against the client machine or running it from the client machine against server machine returns error similar to following.
*** myDNSServer can't find 212.127.168.4:Non-existent domain
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
OpenEdge Server Technology Category: AppServer
All Supported Operating Systems
CAUSE:
The reason for the delay is a DNS misconfiguration. The Progress client asks the underlying TCP/IP layer to resolve the host name after the -H parameter to an IP address, while the AdminServer asks TCP/IP to resolve the IP address of the Progress client to a host name. If DNS is not properly configured, the DNS waits for a time out to expire before going back to the calling process.
The AdminServer and/or the Progress client must also wait, thus giving the impression that the CONNECT() method is slow.
FIX:
Because DNS misconfiguration is an OS problem, not a Progress issue, only a few tips can be given. Refer to the OS documentation for further information.
In the TCP/IP configuration for both workstations, you can however:
- Verify that the domain name matches the actual domain name. MyDomain is not the same as mydomain.com.
- Verify that the IP address for the DNS server is correct.
- If you use multiple DNS servers, verify that the quickest and most reliable one appears at the top of the DNS server list.