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Kbase 20071: Error 247 Using Crystal Reports via ODBC Driver
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Unverified

FACT(s) (Environment):

Progress 9.x

SYMPTOM(s):

Unable to understand after -- "<string>". (247)

Report fails after third table link is made.

Using Crystal Reports 7 to connect via the SQL-92 ODBC Driver.

CAUSE:

This problem is directly related to Crystal Reports.

FIX:

The Seagate website has a workaround for the problem.
Follow the following steps:

1) Go to the following URL:

http://support.crystaldecisions.com/

2) Search for "odbcregs.zip".
This brings up a page where the "odbcregs.zip" file can be downloaded.

3) Execute the "OUTJOIN.REG" file which is one of the six files in the zipped files.

NOTE: The p2sodbc.dll file does not need to be replaced with the one included in the zipped file because the newer version all ready is present.

4) Get the file name for the ODBC driver.
a)Go into Control Panel and open the ODBC Administrator.
b)Click the User/System tab.
c)Find the ODBC data source.
d)Look at the driver name that corresponds with that data source then click on the Driver Tab.
e)Look up that driver name (the file name is to the right of that line.
For example:
Driver Name..Filename
CROR7.......cror713.dll

5) Edit the Registry to add the file name. (Always back up the Registry before modifying it).
a)Go to the the following key:
HKEY_CURRENT_USER > SOFTWARE > SEAGATE SOFTWARE > CRYSTAL REPORTS > DATABASEOPTIONS > OUTERJOIN
b)Click on the PlusEqual label, right click and choose to "modify".
c)Add the file name (without the .DLL).
Default..........value not set
AccessDriver...."odbcjt16,odbcjt32,qbodbc"
DataBaseName...."qeinf506,qeinf507"

6)Open Crystal Reports.
The SQL syntax should have changed to be the correct syntax for the database.