Consultor Eletrônico



Kbase 19991: Why can't some tables be seen from a SQL89 ODBC client application?
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

MERANT 3.50 32-BIT Progress SQL-89
MERANT 3.60 32-BIT Progress SQL-89
MERANT 3.70 32-BIT Progress SQL-89
MERANT 4.0 32-BIT Progress SQL-89
Windows
Progress 8.x
Progress 9.x

SYMPTOM(s):

Can't see some tables through SQL89 ODBC client application.

CAUSE:

This is typically rooted in the permission settings for the problem tables (i.e. can-create, can-read, can-write, etc...) In other words, the user connected to the database lacks the necessary permission to access the table.

FIX:

From the Data Administration tool, select:

>Admin
>Security
>Edit Data Security

Change the necessary permissions (i.e. can-read, can-write, can-create, can-delete. etc...) on the table(s) that can't be seen from the ODBC client application for the effected user(s).