Consultor Eletrônico



Kbase 19932: Table/View/Synonym Not Found (7519) in Actuate v4.1 using SQL92
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Unverified

FACT(s) (Environment):

Progress 9.x

SYMPTOM(s):

Actuate 4.x

Table/View/Synonym not found (7519)

CAUSE:

The error appears because in SQL-92 you must make reference to the schema that identifies where the table you want to use is.

FIX:

There are two ways to solve the problem in Actuate 4.1. Using PUB.Customer as an example, these are:

1) Use the wizard option when you create a new report.
If you use this option, the problem is avoided because Actuate writes the schema name in the clause 'FROM' (Ex: "PUB"."Customer").

2) Change the property Name Qualification.
If you use the SQL editor, Actuate will not write the schema name in the clause 'FROM' and the Error 7519 is displayed. To solve the problem, change the property Name Qualification in the table properties to "qualifier.owner.table."