Kbase 19360: Databases don't show in Progress Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.X.
SYMPTOM(s):
Database folder not visible from Progress Explorer
Can not see databases folder from Progress Explorer
[*UnexpectedError*] * recorded as exception #n in file ads0.exp.
[AdminServer] * Juniper not installed: Plugin asked not to be installed. (7439)
[AdminServer] * Failed to install plugin Juniper. (7433)
Errors present in admserv.lg file
java.net.BindException: Address already in use
Exception at Mon Dec 27 09:24:40 EST 1999: java.net.BindException
Message (throw): Failed to establish remote socket connection.
Message (excp): Address already in use
Stack Trace:
java.net.BindException: Address already in use
at java.net.PlainSocketImpl.bind
at java.net.ServerSocket.<init>
at java.net.ServerSocket.<init>
at com.progress.common.comsock.ServerComSock.connect
at com.progress.juniper.admin.JAPlugIn.initSocket
at com.progress.juniper.admin.JAPlugIn.init
at com.progress.chimera.adminserver.AdminServer.installPlugin
at com.progress.chimera.adminserver.AdminServer.installPlugins
at com.progress.chimera.adminserver.AdminServer.setupPlugins
at com.progress.chimera.adminserver.AdminServer.<init>
at com.progress.chimera.adminserver.AdminServer.<init>
at com.progress.chimera.adminserver.NonNTAdminServer.<init>
at com.progress.chimera.adminserver.OSSpecific.getAdminServer
at com.progress.chimera.adminserver.AdminServer.main
Exception recorded in ads0.exp file
CAUSE:
The AdminServer has two ports set aside for use which can be configured from the proadsv command line. The port referenced by -port is the main AdminServer listening port, where all queries, and start/stop requests are sent. By default, this is port 20931.
The port referenced by -adminport is used by databases to communicate with the AdminServer. By default, this is port 7832.
When the AdminServer is started, it loads (or "installs") "plugins" based on the licenses that are installed. These plugins provide the functionality for the various components the AdminServer will control. As part of the install of the database plugin, the AdminServer will try to set up a server socket (listener) for the adminport for the databases to communicate with the AdminServer.
When connecting the Progress Explorer to the AdminServer, the Explorer loads information for all the installed plugins on the AdminServer. If the database plugin failed to install, the Databases folder will not be seen in Progress Explorer, despite the Progress licenses installed on the server.
The reason for the database plugin to fail to install on the AdminServer and for the exceptions is the adminport port is in use. If this port is in use already, another server socket cannot be created using this port.
This can happen if there are two Adminservers running on two different ports (possibly from two different versions of Progress). You might start one Adminserver on port 20931, and a second one on port 20930. If a separate -adminport is not specified, they will both try to open port 7832, and one of them will fail.
Another reason is that the port 7832 (or -adminport) is already in use by some other process (possibly a database server).
NOTE: the value of -adminport should NOT be the same port intended to use for the database server. These are two different ports, for different purposes.
FIX:
Change the port number using the -adminport parameter when you start the AdminServer.
1, Syntax for UNIX: proadsv -port 20000 -adminport 8000
2- If you want to change the -adminport that the AdminServer service uses on Windows NT or 2000, follow these steps:
1) Go to the Control Panel / Services. Make sure you stop your
AdminServer service.
2) Run regedit. You will have to add the -adminport argument
along with the port number to the startup and shutdown
entries in your Registry.
The registry keys are:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\(version of
Prog.)\StartupCmd
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\(version of
Prog.)\ShutdownCmd
An example of the 'edit string' in your Registry would be:
"C:\V9\bin\jvmstart" -o eventmgr -w @{WorkPath}
@{JAVA\JREHOME}\bin\jre -classpath
@{JAVA\JRECP};@{JAVA\PROGRESSCP}
-DInstall.Dir=@{Startup\DLC} -DWork.Dir=@{WorkPath}
com.progress.chimera.adminserver.AdminServer
-adminport 7834
NOTE: Notice that the -adminport 7834 has been added to the end of the string. Be careful when editing the registry manually. You should not change the other parameters in this registry key, unless instructed to do so, or your AdminServer might not start up again.
You can also verify that the correct port was used in the database log file. The port used will be recorded in the startup section.