Consultor Eletrônico



Kbase 18974: Errors 4393 & 5644 occur when using SQL-92 with ProVision, ProVision Plus, 4GL Development or OpenE
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   8/6/2010
Status: Verified

SYMPTOM(s):

Errors 4393 & 5644 occur when using SQL-92 with ProVision, ProVision Plus, 4GL Development or OpenEdge Studio licenses

Remote progress client recieves error 1432

** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)

SQL-92 client receives ODBC PROGRESS driver error

[DataDirect][ODBC PROGRESS driver]Invalid attribute in connection string.

[DataDirect][ODBC PROGRESS driver]Error in Network Daemon.

Cannot connect a remote progress client (prowin32 and/or _progres_) to database

Database server log reports errors:

This server is licensed for local logins only. (4393)

One of the licenses has only been installed on server; i.e., Provision, Provision Plus, 4GL Development or OpenEdge Studio

Error received even after starting a database sever with networking parameters -H hostname -S portnumber

Unable to establish a remote ODBC connection

Cannot use SQL-92 remotely

[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]Connection refused. Verify Host Name and Port Number.

FACT(s) (Environment):

All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

CAUSE:

The messages appear because the Provision, Provision Plus and OpenEdge Studio products include only a personal database designed for local connections only.

FIX:

When you start a local database server, it listens for connections at the localhost interface only.
This allows connection to the SQL-92 engine only from the same machine using networking parameters.

So you have 2 options:
Option 1:
1. Start database using -S parameter only
2. Connect to local database using -H localhost -S

Option 2:
1. Add a database license such as OpenEdge Workgroup RDBMS or OpenEdge Enteprise RDBMS.