Consultor Eletrônico



Kbase 44416: Erros ORA-12170 e ORA-12541 causando instabilidade no appserver do TSS
Autor   Kleber Eduardo Clemente - CAT
Acesso   Público
Publicação   7/27/2011
Problema:
Servidor do TSS falhando com as seguintes mensagens:
- ORA-12170 - TNS:Connect timeout occurred
seguida de
- ORA-12541 - TNS: no listener

Plataforma:
Todas

Causa:
Esta situação ocorre quando o servidor do TSS não está conseguindo concluir uma conexão com o banco Oracle em tempo hábil, tempo este especificado pelo parâmetro SQLNET.INBOUND_CONNECT_TIMEOUT do arquivo 'sqlnet.ora'. Isto pode ocorrer devido a alguma lentidão ou falha de comunicação de rede entre estas duas máquinas (mesmo que intermitente), ou também quando o servidor do TSS está bastante carregado, o que também influencia no tempo para que esta conexão ocorra.

Solução:
Alterar o tempo de timeout de conexão entre o client e o server do Oracle.
Para isso insira o seguinte parâmetro no arquivo 'sqlnet.ora', localizado no servidor do banco de dados, na pasta de instalação do Oracle, na sub-pasta 'network/admin':
SQLNET.INBOUND_CONNECT_TIMEOUT=120
O padrão deste parâmetro, quando inexistente, é 60 segundos. Neste caso estamos aumentando o tempo de conexão para 2 minutos.