Kbase P187953: Sonic ABL adapter stops consuming messages
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  19/05/2011 |
|
Status: Unverified
SYMPTOM(s):
Sonic ABL adapter stops consuming messages
AppServer Boker log shows that the agent stops
ServerSocketsIPC read() IOException : java.net.SocketException: Connection reset : Connection reset (8127)
ServerSocketsIPC <operation> IOException : <IOException_string> : <IOExceptionMsg_string> (8127)
ServerIPCException in getServerIPCMsg() : ServerIPC error: ubServerSocketsIPC.read() IOException: Connection reset. (8119)
ServerIPCException in <funcName> : <ServerIPCException_string>. (8119)
Posted EAbnormalShutdownServerEvent for PID: 7940
Client disconnected : . (8534)
Client disconnected : <socketInfo>. (8534)
Error Unspecified Error ... disconnecting client. (8091)
Error <errMsg> ... disconnecting client. (8091)
AppServer server stops due to a disk error.
Insufficient disk space or Write access denied. (291)
FACT(s) (Environment):
Sonic ABL adapter is used by an AppServer agent
All Supported Operating Systems
OpenEdge 10.x
CAUSE:
The Sonic ABL adapter agent disconnects from AppServer agent because it stops due to lack disk space.
FIX:
Add disk space, trim AppServer log files or redirect the AppServer to use a different disk using the -T startup parameter.