Kbase P187851: Client Server application connection is being reset after 45 minutes of inactivity as SERVER-CONNECT
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/17/2011 |
|
Status: Unverified
SYMPTOM(s):
Client Server application connection is being reset after 45 minutes of inactivity as SERVER-CONNECTION-CONTEXT being reset to null which results error 13767 in the stateless AppServer broker log
The ASK major version was missing in the CONNECT request (<exception>). AppServer Keepalive protocol is disabled for this connection. (13767)
The ASK major version was missing in the CONNECT request (com.progress.ubroker.util.ubMsg$TlvFieldNotFoundException: TlvAccessException). AppServer Keepalive protocol is disabled for this connection. (13767)
Clients' application uses SERVER-CONNECTION-CONTEXT for entire session to connect to AppServer
FACT(s) (Environment):
If user works on the gui application everything works fine
The problem is apparent when end user leave for 45 minutes while the client session to AppServer is open
AppServer and the database are running on a different subnet than the GUI clients
Each subnet has firewall
The firewall timeout for inactivity on the AppServer subnet is set to 45 minutes
The firewall timeout for inactivity on the clients' subnet is set to 1 hour
The TCP idle timeout on the Linux server is 2 hours
All Supported Operating Systems
OpenEdge 10.x
CAUSE:
The firewall timeout on the AppServer subnet is closing the connection between AppServer and the GUI client. This causes the SERVER-CONNECTION-CONTEXT attribute value to be reset to unknown.
FIX:
Change the TCP idle timeout on the AppServer server to less than 45 minutes to resolve this issue.